Instant On - Wireless

  • 1.  Custom DNS entries are deleted after some time

    Posted 05-25-2021 02:45 PM
    Hi all, since I setup custom DNS entries for one of my sites I have experienced twice that these entries are deleted by some unknown reason. The first time this happened after maybe two weeks after I initially set them up, but it took only a few days for this to happen the second time.

    Does anyone has this problem too?

    Regards.


  • 2.  RE: Custom DNS entries are deleted after some time

    Posted 05-26-2021 10:28 AM
    On which device are you configuring the custom DNS entries?

    ------------------------------
    Valentin Voica
    ------------------------------



  • 3.  RE: Custom DNS entries are deleted after some time

    Posted 05-26-2021 10:45 AM
    Hi, the site has an AP11D.


  • 4.  RE: Custom DNS entries are deleted after some time

    Posted 05-26-2021 02:38 PM
    Hi,

    I'm afraid I don't have access to an AP11D to check, and I couldn't find any information about the DNS resolver built into the AP11D's router features.

    Just to be clear, by "custom DNS entries" you mean "DNS overrides", similar to the screenshot below (from Unbound DNS):




    ------------------------------
    Valentin Voica
    ------------------------------



  • 5.  RE: Custom DNS entries are deleted after some time

    Posted 05-26-2021 02:51 PM
    Thank you for your reply.

    More or less what you mention, there is an option for entering custom DNS entries for a site. DNS addresses entered here will be the ones that the Instant ON AP will assign to clients:

    DNS



  • 6.  RE: Custom DNS entries are deleted after some time

    Posted 05-27-2021 04:03 AM
    OK, that's not DNS overrides - to be honest, I would have been surprised to find a DNS resolver in Aruba Instant On.

    That's just to configure a preferred DNS server for your Instant On network (as explained in the Aruba Instant On official documentation here).

    If your network is segmented (using VLAN's) you will need an external DHCP server. If you use a flat network - let's say you have two wired clients patched directly into interfaces on AP11D, and the rest are wireless clients connected to the network using a single SSID then:

    • the wired clients must be configured with a static IP address, or lease an IP address from a DHCP server on your network (let's say, you have an ISP issued modem / router which has DHCP services configured) - this service will issue the DNS server for its clients. In this case, the DNS server used by your wired devices willbe the one configured on the ISP router
    • the wireless clients will be assign a dynamic IP address by your Instant On network (NAT mode):
    NAT mode
    In this case, the DNS server assigned to the wireless clients should be the one you configured on the Aruba Instant On network, as shown in your screen capture. If this is not the case, there may be a bug, so I would recommend using the Bridged Mode option and an external DHCP service: your ISP router, same as the wired clients, or a Raspberry Pi with Pi-hole - a much better option.


    ------------------------------
    Valentin Voica
    ------------------------------



  • 7.  RE: Custom DNS entries are deleted after some time

    Posted 15 days ago
    Yup, same with firmware 2.4.0.

    I can set custom DNS while wireless network is in NAT mode, but after a while custom DNS settings seem lost/deleted.

    -edit-

    Seems to only happen sometimes when changing network access settings in wireless network. 

    When not changing other settings, also custom DNS settings seem stable.

    ------------------------------
    Chris NA
    ------------------------------