Mobile App

Expand all | Collapse all

Constant app warning "Your internet connection appears to be offline"

  • 1.  Constant app warning "Your internet connection appears to be offline"

    Posted 01-05-2021 10:50 AM
    Installed the App got my new AP22 setup just fine, but once I connect my phone (S10) to that SSID, the InstantON app shows a black bar across the bottom of the screen continually with the warning "Your internet connection appears to be offline". It's there as long as I am in the App and connected to the AP22. However, the phone internet (through the AP22) is just fine.

    I put the phone into airplane mode, and switched on just the wifi to make sure it was through the AP. The AP is behind a NAT/firewall but it works fine for everything else - browser speedtest etc. No android warning on internet connectivity, just the app. Is it trying to get IPv6 connectivity?

    What gives? The warning blocks off the bottom of the app and prevents me from selecting things there...

    Thanks

    Tim


  • 2.  RE: Constant app warning "Your internet connection appears to be offline"

    Posted 01-05-2021 06:25 PM

    I *think* the issue was DNS - the AP22 defaults to using CloudFlare DNS servers, but my firewall blocks DNS bypass and and only allows DNS queries to the one provided by DHCP. Setting this in Device->Access Details and then the "..." menu DNS lets you select "DHCP" assigned DNS.

    That it defaults to something other DHCP assigned is really bad - I expect it has to do with the default "content classification" setting? Which I also strongly dislike.



    ------------------------------
    F L
    ------------------------------



  • 3.  RE: Constant app warning "Your internet connection appears to be offline"

    Posted 01-20-2021 11:49 AM
    Hi Tim,

    I got the same issue...Were you able to resolve this? How?

    Much appreciated :)

    ------------------------------
    F L
    ------------------------------



  • 4.  RE: Constant app warning "Your internet connection appears to be offline"

    Posted 01-20-2021 12:19 PM

    In the web portal for DNS click into inventory and then click the cogwheel on the right had site and then select DNS and make your changes. For DPI click on applications then click on the cogwheel and select Application activity summary to turn off DPI.



    ------------------------------
    Greg Thiesen
    ------------------------------



  • 5.  RE: Constant app warning "Your internet connection appears to be offline"

    Posted 01-20-2021 01:45 PM
    Thanks Tim,

    Somehow I managed to block my own phone, dah! Unblocking myself resolved the issue for me :)

    ------------------------------
    F L
    ------------------------------