Instant On - Wireless

 View Only
  • 1.  AP11D not getting IP from DHCP - not connecting to cloud

    Posted 9 days ago

    Hi all,

        I have an AP11d that after a power outage will no longer get an IP from the DHCP server. I have tried with all the 3 ETH ports and even changed patch, the link comes up but the green LED just remains flashing and eventually resets. So I went ahead and hard reset it - it eventually flashes green and orange as it's ready to be "adopted" but it still fails to get an IP and so is unable to be detected by the app/cloud portal. I tried it from another connection and switch in my office but no go, same thing happens. I'm afraid that there is some major connectivity issue with the internal hardware at this point as it was working fine before this outage (it's about 4 years old).

    Do you have other suggestions that may help in recovering the AP? Is there no possibility to directly connect to it to see what's going on (I see no serial/termina port apart from the USB port)?

    Thanks



    ------------------------------
    Luca
    ------------------------------


  • 2.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 9 days ago

    I would remove the AP from the LAN and connect a PC to the cable instead to check whether it is the DHCP server or the AP. If the PC gets an IP, the AP probably has a problem.

    ciao

    ryder



    ------------------------------
    Ryder Hook
    ------------------------------



  • 3.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 9 days ago

         The DHCP Server is working correctly as I can see the other devices' IPs in the DHCP leases table (and they connect). I also tested it on our Office network and no IP is handed out to this AP. It seems like the AP is really broken - bummer.



    ------------------------------
    Luca
    ------------------------------



  • 4.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 9 days ago

    I made the suggestion to test the dedicated port and cable. If other devices have an IP, this is no proof that the DHCP is working. Depending on the configured lease time, another client may not realise that the DHCP is not working. This is only detected when the client requests a new IP. 

    Otherwise, I have no idea if you have already tried to reset the AP.



    ------------------------------
    Ryder Hook
    ------------------------------



  • 5.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 9 days ago

        I brought the AP at my office where I have a functional DHCP server where I have a guest/test vlan with a 1hr lease time where I test various appliances and here it also does not acquire an IP. I also have an arp monitor (arpwatch) on my firewall which sends me notifications of new ARP traffic and MAC address flip-flops on new leases - also no detection. A packet capture also revealed no ARP traffic from the AP MAC address over the whole initialization time span until it reached green/orange (where it should request an IP) and resets after. That thing is definitely a dead weight atm. My curiosity was if for ex. the back console serial port (proprietary pinout which seems similar to the ones used on some MSA storage devices) could be used to monitor boot activity and get an idea of what is failing - but I guess at this point I'll tell the client he needs to purchase a new one as this one is just over 2 years old and out of warranty.

    Thanks



    ------------------------------
    Luca
    ------------------------------



  • 6.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 8 days ago

    No. You need a dedicated USB to Serial cable (orange one) to be able to connect to console port. AP-CBL_SERU PN:JY728A.

    Try to factory reset AP with reset button.

    Best, Gorazd



    ------------------------------
    Gorazd Kikelj
    ------------------------------



  • 7.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 8 days ago

        Just as an update, I wired together a microUSB to TTL cable (the suggested JY728A is a microUSB to USB cable with internal USB to RS232 TTL converter like the FTDI232 or Prolific PL2302 converter chips wired to the microusb pins corresponding to RX, TX and GND or 2, 3 and 5) and connected to the AP - it booted regularly and no errors were logged apart from not getting an IP and reverting to the auto IP after some time. I rebooted an pressed enter to enter the bootloader. I then tried to launch the dhcp client option and again trying various ports it always timed out after 5 attempts. At this point I had nearly given up so I tried the last "Factory Reset" option which it executed (I did reset it previously through the reset button keeping it pressed for 10 seconds and even 15 at power on). I entered again the boot loader and tried the dhcp option once more and this time (on port E0) it got an IP. I then booted it and voilà miraculously it got an IP and was discovered and imported it back to the site. I don't know why a bootloader Factory Reset worked and a "manual" reset didn't (?) but anyhow at least it's back to life. Thanks!



    ------------------------------
    Luca
    ------------------------------



  • 8.  RE: AP11D not getting IP from DHCP - not connecting to cloud

    Posted 7 days ago

    Hi Luca.

    Glad that you resolve the issue. Reset button not resetting to complete factory default is a know behavior on APs. Sometimes you just must use boot loader factory reset command to really reset the AP.

    Best, Gorazd



    ------------------------------
    Gorazd Kikelj
    ------------------------------